Compter le nombre d'erreurs dans une plage


#1

Bonjour

Je voudrais savoir s’il existe une formule qui permette de compter le nombre d’erreurs dans une plage voire même dans toute la feuille?

Est-ce possible de renvoyer leurs adresse également?

Merci pour votre dépannage


#2

Bonjour karimd,

Pour compter le nombre d’erreurs dans une plage, j’ai choisi “A1 à B10”, mais tu peux sélectionner toute la feuille sauf la cellule ou se trouve la formule.

=SOMMEPROD(--ESTERREUR(A1:B10))

Par contre renvoyer l’adresse exacte des erreurs, c’est sans doute possible de créer une liste par VBA, mais à ce stade, je ne sais pas faire.

Cordialement.


#3

Re,

Je viens de trouver une macro VBA qui donne l’adresse des erreurs dans une plage via une MsgBox .
Pour accéder à la macro faire (alt + F11) et modifier la plage dans:
Range("A1:B10")

Je te joins un p’tit fichier ==> ICI karimd V1.xlsm (17,0 Ko) pour que tu en vois le fonctionnement.

Cordialement.


#4

@karimd,

Bonjour, si ton problème est résolu, merci de sélectionner.


#5

Bonjour

Merci beaucoup pour ta formule et ta macro

Cependant je ne comprends pas tellement comment fonctionne les – (moins moins) dans ta formule[quote=“mdo100, post:2, topic:287”]
=SOMMEPROD(–ESTERREUR(A1:B10))
[/quote]


#6

Bonsoir karimd,

Les 2 tirets, Il s’agit de transformer des valeurs booléennes qui renvoies une valeur logique “VRAI ou FAUX” en 1 ou 0 pour les exploiter dans la formule.
Comme tu as pu le voir, pour obtenir une erreur, j’ai volontairement additionné une lettre à un chiffre le résultat est donc pour Excel FAUX et ça je ne peux rien en faire, alors la fonction matricielle SOMMEPROD permet d’utiliser 2 tirets ou *1 pour renvoyer des valeurs numériques exploitables en 1 ou 0.
Donc j’aurais pu aussi écrire la formule comme ceci:

=SOMMEPROD(ESTERREUR($A$1:$B$10)*1)

Cette explication te convient-elle ?

Si ton problème est résolu, n’oublie pas de cliquer sur :white_check_mark:

Cordialement.