Compte le nombre de ligne unique avec tel critère


#1

Bonjour,

J’ai un excel de 20 000 lignes qui retrace le traitement de fichier.

certaines lignes peuvent correspondre au même fichier mais je voudrais compter en réalité combien de fichiers ont été intégré. Voici un exemple de base de donnée:

Fichier 1 Intégré
Fichier 2 Erreur
Fichier 2 Intégré
Fichier 3 Erreur
Fichier 3 Erreur
Fichier 4 Intégré
Fichier 5 Intégré
Fichier 6 Erreur
Fichier 6 Erreur
Fichier 6 Intégré

Dans cette base j’ai 10 lignes mais seulement 5 fichiers intégrés.

Merci pour votre aide !


#2

Bonjour
Tu souhaites en fait compter le nombre de fois ou apparait la valeur " Integre"
Dans ce cas tu peux utiliser la formule NB.SI qui repond a cet objectif

=NB.SI(C:C;"Integre")


#3

Merci…

En réalité mon fichier est beaucoup plus complexe et je cherchais quelque chose de bien plus compliqué !!

#simpleisthemostdifficult


#4

Du coup la solution te convient je suppose? :grin:


#5

Oui ! Par contre si j’ai par erreur plusieurs fichiers intégrés

ex:
Fichier 1 Intégré
Fichier 2 Erreur
Fichier 2 Intégré
Fichier 3 Erreur
Fichier 3 Erreur
Fichier 4 Intégré
Fichier 5 Intégré
Fichier 6 Erreur
Fichier 6 Erreur
Fichier 6 Intégré
Fichier 6 Intégré

Le NB.SI me donne 6 mais moi je considére que ça ne compte en réalité que pour un fichier…

Je voulais compter le nombre de doublons (ici 1, il y deux lignes avec en colonne A “Fichier 6” et en colonne B “intégré”) sur les deux colonnes pour les soustraire au total (ici 6) pour me donner le bon total réel (5)
mais sans faire un concatener puis fonction Si(NB.SI($A1:$A$1;A2)=0;1;°0) car ça allourdit trop le fichier.

Tu as une idée ?


#6

La maniere dont je procederais:

  • Dans une nouvelle colonne, isoler uniquement les numeros de fichier integres avec une fonction SI
  • Compter le nombre de valeurs uniques dans cette colonne avec la formule

=SOMME(SI(FREQUENCE(A2:A11;A2:A11)>0;1))

Cela fait 1 calcul suppementaire par ligne + 1 calcul sur toute la colonne a la fin

cf ce tutoriel


#7

Bonjour @AugustinJ, @DocteurExcel,

Un fichier est toujours le bienvenu, plutôt que d’être obligé de le reconstituer. :wink:

Bon, pas sûr d’avoir tout compris, mais je tente ma chance.

Voici ma proposition a adapter au fichier réel:

Supposons que les données soient dans les colonnes “A & B” à partir de la ligne 2.

En “C2”:

=SI(B2="Erreur";"";A2&B2)

Tirer la formule vers le bas.

Puis dans la cellule que tu veux ! Formule matricielle donc a valider avec ctrl + maj + entrée

=SOMME(SI(C2:C12<>"";1/NB.SI(C2:C12;C2:C12)))

Cela convient-il ?

Et puisque j’ai fais un fichier, je le joins ICI==> AugustinJ V1.xlsx (14,3 Ko)

Cordialement.