Comparer multiples plusieurs colonnes


#1

bonjour à tous
je voudrais comparer plusieurs colonnes entre elles. Voici un exemple, j’ai pris un appartement par souci de simplification.

Il s’agit de comparer les composants du nouveau bien par rapport à l’ancien. L’élément de base est le n° 40 et sa référence associée. Donc est-ce que la ref 6948-45J correspondant à la cuisine sur le nouveau bien existe dnas l’ancien en termes identiques ? Dans le nouveau, la caractéristique liée à la ref 6948-56K est salons (avec un s) dans le nouveau, alors qu’elle est sans s dans l’ancien.
Ci joint le fichier.

Merci de votre aide.

appartements.xlsx (8,9 Ko)


#2

Bonjour @MMM,

Voici une proposition:

Un petit tableau de comparaison que j’ai placé en colonne “J”:

Formule en “J5”:

=SI(ESTNA(EQUIV(D5;H:H;0));D5&" - Manquant dans nouveau";RECHERCHEV(D5;H:H;1;0)&" - OK")

Voir aussi les MFCs:

Formule pour Rouge:

=DROITE($J5;21)="Manquant dans nouveau"

Formule pour Vert:

=DROITE($J5;2)="Ok"

Ci-joint le fichier modifier ICI==> MMM V1.xlsx (12,5 Ko)

Cordialement.