Comparaison de deux colonnes dans Excel


#1

dans deux colonnes Excel se trouvent les mêmes données dans l’ordre différent. comment repérer les cellules
contenant les mêmes données automatiquement ?


#2

Bonjour à toi aussi
Je ne suis pas certain d’avoir compris ta question. Peux-tu nous donner plus de détails stp et inclure un fichier d’exemple afin que nous puissions mieux comprendre?


#3

Bonjour @Jaroslaw_M,

Salut @DocteurExcel,

“La politesse est comme le zéro, qui, sans avoir de valeurs en soi, en ajoute à toutes choses.”

Plusieurs solutions sont possibles.

Dans cette attente essai cette formule.

=SI(Bonjour; Alors une solution sera trouvée; Sinon RIEN)

Cordialement.


#4

dans le cas de quatre colonnes à 4000 lignes :
137989 AO 13272 P387150 AO 10288
137990 AO 13273 P387236 AO 10289
137991 AO 13274 P387155 AO 10290
137992 AO 13275 P387189 AO 10291
137994 AO 13277 P387214 AO 10292
137995 AO 13278 P387147 AO 10293
137996 AO 13279 P387096 AO 10294
137997 AO 13280 P387121 AO 10295
137999 AO 13282 P387239 AO 10297
138000 AO 13283 P387071 AO 10298
138001 AO 13284 P387126 AO 10299
je dois trouver les mêmes numéros AO dans la colonne 2 et 4 et identifier les cellules correspondantes. Est-cela possible? Merci pour votre aide.


#5

Bonjour, Bonjour @Jaroslaw_M,

Je maintiens que dire BONJOUR au début de tout nouveau message est une formule de politesse la plus basic du savoir vivre.

Voici un exemple de comparaison pour 2 colonnes.

En colonne “F” à partir de “F2” et tirer vers le bas.

=SI(ESTNA(EQUIV(B2;D:D;0));B2&" - Manquant Col D";RECHERCHEV(B2;D:D;1;0)&" - OK")

Voir aussi les MFCs:

Couleur Bleue:

=ET($B2;DROITE($F2;2)="OK")

Couleur Rouge:

=DROITE($F2;14)="Manquant Col D"

Et un fichier pour l’exemple ICI==> Jaroslaw_M V1.xlsx (12,9 Ko)

Cordialement.


#6

Bonjour,

Merci de m’avoir répondu malgré ma grossièreté impardonnable. Je m’incline devant la solution!

Cordialement


#7

Re @Jaroslaw_M,

Pas de quoi, je le fais avec plaisir et passion d’Excel, heureux de t’avoir rendu service et de la validation de cette solution. :wink:

N’oublie pas de revenir sur le forum si tu as besoin.

Bonne soirée.