Comment calculer une moyenne d'ancienneté


#1

Bonjour,

J’ai crée un tableau avec une colonne ancienneté calculée en année et mois.
Dans une autre feuille, j’ai un tableau de calcul par service. j’aimerais calculer la moyenne d’ancienneté par services. j’ai tout essayé mais j’y arrive pas. même en créant un TCD avec 2 données (service, ancienneté)
Aidez moi svp


#2

Bonjour @BELIX59,

Aurais-tu un p’tit bout de fichier a nous fournir pour illustrer ta demande, si données sensibles alors anonymiser le fichier.

Pour joindre un fichier:

@+


#3

tableau-de-bord rh 2016 anoyme.xlsx (53,6 Ko)

Merci,

J’ai modifié la formule de calcul ancienneté pour avoir un graphique représentatif mais je préférerai que celà indique x années, x mois


#4

Re @BELIX59,

Voici une proposition si j’ai bien compris:

Dans la feuille “agent” colonne “M” à replacer dans la colonne “E”.

=SI(D3<>"";DATEDIF($D3;AUJOURDHUI();"m")/12;0)

Dans la feuille “Calcul” colonne “K” à replacer dans la colonne “J”.

=SOMMEPROD((agent!$F$3:$F$73=$A15)*(agent!$M$3:$M$73))/$G15

Fichier ICI==> BELIX59 V1.xlsx (57,9 Ko)

Cordialement.