Calendrier sans les week end


#1

Bonjour à tous,

je cherche une formule pour faire un calendrier sans les week end, j’ai trouvé des formules mais quand le mois commence un dimanche sa fonctionne pas

merci


#2

Bonjour @Barttsi,

Il faut commencer par écrire dans une cellule l’année.

En “A1” ==> 2018

Puis cette première formule pour obtenir le premier lundi de l’année:

En “A2”

=DATE(A1;1;1)-JOURSEM(DATE(A1;1;1)-2+7)+7

Puis pour le reste des jours de l’année sans les week-end.

En “A3”

=SERIE.JOUR.OUVRE(A2;1)

Tirer vers le bas autant que nécessaire.

Fichier exemple et a adapter ICI==> Barttsi V1.xlsx (11,7 Ko)

Cordialement.


#3

Bonjour à tous
Bonjour MDO100

Ma contribution

image


#4

MDO100 cela fonctionne tres bien mais en 2020 sa ne fonctionne plus

et si je commence mon calendrier en mars 2020 en changeant le mois dans le code sa commence au 5 au lieu du 1

Minimathy cela fonctionne mais si je commence mon calendrier au mois d’avril 2018 comme le premier jours est un dimanche sa ne marche pas il m affichera le dimanche


#5

Re,
En faisant marcher un peu les "Neurones"
on trouve

Sans explication
Barttsi.xlsx (10,4 Ko)


#6

Re @Barttsi,
Salut l’ami @Mimimathy, :wink:

Une autre proposition:

En “A1” l’année
En “B1” le mois en lettre, parce-que j’aime bien :yum: sinon le mois en chiffre dans “C1”.

En “A2”

=SI(OU(JOURSEM(DATE(A1;MOIS(1&B1);1))=1;JOURSEM(DATE(A1;MOIS(1&B1);1))=7);SERIE.JOUR.OUVRE(DATE(A1;MOIS(1&B1);1);1);DATE(A1;MOIS(1&B1);1))

En “A3”

=SERIE.JOUR.OUVRE(A2;1)

Tirer vers le bas autant que nécessaire.

Ou en “C2”

=SI(OU(JOURSEM(DATE(A1;C1;1))=1;JOURSEM(DATE(A1;C1;1))=7);SERIE.JOUR.OUVRE(DATE(A1;C1;1);1);DATE(A1;C1;1))

Ou en “C3”

=SERIE.JOUR.OUVRE(C2;1)

Tirer vers le bas autant que nécessaire.

Fichier exemple et a adapter ICI==> Barttsi V2.xlsx (12,4 Ko)

Cordialement.


#7

merci pour votre aide bonne fin de journée