Calendrier perpétuel avec férié du québec


#1

J’aimerais savoir si on peut faire ton calendrier mais avoir 1 mois de l’année sur chaque feuille indéfiniment?

Docteur Excel
Publiée le 3 févr. 2018

Docteur Excel te montre un exemple de fichier de calendrier 2018 sur Excel

:zap: Télécharge le fichier Excel
https://outwrk.lpages.co/yt-cu-fichie



#2

Bonjour @poulette5380,

Voici une proposition:

Un bouton toupie situé dans la feuille “Janvier” en “A1:A2” de l’année 2015 à 2100, je pense que la perpétuité a des limites en ce bas monde :wink:

Puis une feuille par mois de “Janvier à Décembre”

En “B1:B2” l’année sélectionnée avec le bouton toupie dans la feuille “Janvier”.

En “B3” de chaque feuille le nom du mois avec cette formule.

=STXT(CELLULE("nomfichier";B3);TROUVE("]";CELLULE("nomfichier";B3))+1;20)

Puis en “B4”

=SI(MOIS(DATE($B$1;MOIS(1&$B$3);LIGNE()-3))=MOIS(1&$B$3);DATE($B$1;MOIS(1&$B$3);LIGNE()-3);"")

Tirer la formule jusqu’en “B33” sur chaque feuille des mois de l’année.

Enfin en “A4” si on veut savoir le jour de la semaine.

=SIERREUR(CHOISIR(JOURSEM(B4);"Dim";"Lun";"Mar";"Mer";"Jeu";"Ven";"Sam");"")

Tirer la formule jusqu’en “A33” sur chaque feuille des mois de l’année.

J’allais oublier les jours fériés :roll_eyes:

Donc ajout d’une feuille “Fériés” avec les formules pour calculer les jours fériés du Québec.

Capture

Et pendent qu’on y est des Mises en formes conditionnelles “MFCs” pour identifier les week-end et jours fériés selon les mois dans chaque feuille.

Fichier exemple **ICI==> poulette5380 V1.xlsx (37,8 Ko)

Cordialement.


#3

Bonjour à toi aussi @poulette5380

Oui, par exemple en dupliquant 12 fois la feuille pour avoir les 12 mois

Quelles sont les règles pour les jours fériés du Québec?