Besoin d'aide pour mon fichier excel


#1

Bonjour

je suis nouveau dans votre forum
j’aurais besoin de votre aide concernant mon tableau Classeur1.xlsx (21,5 Ko)
Dans ce fichier Excel, j’ai expliqué l’idée de ma recherche. Merci d’avance de votre aide


#2

Bonsoir TEPS

Et bien venu sur ce forum vous ne serais pas déçu pour ma part je ne suis pas expert mais vous aurez des

gens comptants qui viendrons vous aider :face_with_raised_eyebrow:

J’ais regarder votre fichier :face_with_monocle:

j’ais juste mis une formule en “C5 , C7 JUSQUE C11”

C5===> “=RECHERCHEV(C4;Tableau1[[SN]:[Intervenant]];5)”

C7===> “=RECHERCHEV(C4;Tableau1[[SN]:[Intervenant]];2)”

C8===> “=RECHERCHEV(C4;Tableau1[[SN]:[Intervenant]];3)”

C9===> “=RECHERCHEV(C4;Tableau1[[SN]:[Intervenant]];4)”

C10===> “=RECHERCHEV(C4;Tableau1[[SN]:[Intervenant]];6)”

C11===> “=RECHERCHEV(C4;Tableau1[[SN]:[Intervenant]];7)”

Et une liste déroulante pour les “SN” en “C4”

Comme c’la vous choisissez le “SN” que vous voulez et tous ce met dans les autre cellules

Dite moi ci c’la vous convient si non d’autre forum-eux viendrons a votre aide

Cordialement

@kiss6


#3

Bonsoir TEPS

Excuser moi j’ais oublier de vous rendre votre fichier mille excuse :confounded:

Classeur1 RECHERCHE.xlsx (21,6 Ko)

Cordialement

@kiss6


#4

Bonjour kiss6

Merci d’avoir répondu rapidement.
La liste déroulante que je voulais avoir est sur "Date fin"
Car dans le tableau il peux y avoir plusieurs interventions pour le même “SN” la seule différence se sont les dates d’interventions.
Donc l’idée une fois le “SN” dans “Date fin” une liste déroulante apparait avec les différents dates d’interventions “Date fin”.


#5

Bonjour à tous

Voilà mon test
Pas de tableau dans l’onglet BASE
Une macro s’effectue à chaque Chgt ou ajout des colonnes B et H pour une mise à jour de la colonne K qui créé une liste sans doublons des “SN”

Private Sub Worksheet_Change(ByVal Target As Range) 'A chaque changement sur une cellule colonne C ou F
 If Not Intersect(Range("SN,DateFin"), Target) Is Nothing And Target.Count = 1 Then
   [b2:H1000].Sort Key1:=[B2], Key2:=[F2]
   [b1:H1000].AdvancedFilter Action:=xlFilterCopy, CopyToRange:=[K1], Unique:=True 'Un filtre se met à jour colonne K avec le SN sans doublons
 End If
End Sub

Toutes les colonnes de l’onglets BASE sont rendus dynamiques dans le gestionnaire de noms

Liste déroulante unique des SN
Liste déroulante DATEFIN par rapport au SN
Le reste des cellules se mettent à jour à l’aide de la formule matricielle (validation par CTRL MAJ Entrée)
en changeant à chaque fois la plage de l’INDEX, par la plage correspondante (sur cette formule: DateDebut)

=SIERREUR(INDEX(DateDebut;EQUIV(1;(SN=$C$4)*(DateFin=$C$5);0));"")

TEPS.xlsm (24,2 Ko)


#6

Merci beaucoup Mimimathy

C’est exactement se que je voulais

Comme on dit Tahitien Maururu roa


#7

Re,

N’oublie pas de passer le sujet en résolu :wink:


#8

Bonjour Mimimathy

Je reviens vers toi pour te demandé par rapport au fichier excel
Excuse moi je suis vraiment un débutant dans tous se qui est VBA
Les codes vba que vous avez mis dans le fichier excel nommé “TEPS.xlsm”, je n’ai réussi à comprendre, donc je n’ai pas réussi à faire la même chose sur mon vrai fichier
Donc STP pouvez vous faire la même chose sur mon fichier LISTE D’INTERVENTION.xlsm (72,6 Ko)

La même chose que vous avez fait pour la fonction "RECHERCHER"
De plus si vous pouvez aussi faire pour la fonction “MODIFIER”

Maururu


#9

Bonjour,
Voilà la modification pour la façon de rechercher
on choisit le MODEL, Puis la Date de Fin et le reste s’affiche

Et comme dis précédemment PAS DE TABLEAU

Pour ce qui est de la modification et la création, ce n’est pas sur cette feuille et avec ce principe
pour exemple: si tu modifie un motifs, comme il y a une formule, elle s’efface pour laisser ta modif
et ensuite, il n’y aura plus de recherche.
Si tu avais posé ta question, dés le départ, avec ce que tu voulais faire, et bien le travail que j’ai fait pour résoudre le 1er post ne serait pas le même
Il te reste pour modifier ou créer avec ton principe de le faire sur des feuilles séparées

LISTE D’INTERVENTION V2.xlsm (64,6 Ko)


#10

Merci beaucoup Mimimathy
Pour le travail que tu as fais, ainsi que pour les conseilles


#11

Bonjour

Si ton problème est résolu, peux-tu stp cocher le petit :white_check_mark: sous le message qui contient la solution stp?

Cela nous aide à déterminer qui a encore besoin d’aide et qui est sauvé!

Merci