Aide traduction formule plusieurs conditions avec des nombres compris entre x et y


#1

Bonjour,

je cherche à traduire cette formule mais je n’y parviens pas. Le fait qu’il y ait plusieurs conditions et des chiffres compris entre deux autre semblent me bloquer…

si b3 est compris entre 18 et 25 alors le résultat est « 18-25 » ; si b3 est compris entre 26 et 30 alors le résultat est « 26-30 » ; si b3 est compris entre 31 et 40 alors le résultat est « 30-40 » ; si b3 est supérieur à 40 alors le résultat est « 40 et + »

auriez-vous la solution ?
Merci d’avance !


#2

Bonjour,

Une proposition :

=SI(B3<=17;"";SI(ET(B3>=18;B3<=25);“18-25”;SI(ET(B3>=26;B3<=30);“26-30”;SI(ET(B3>=31;B3<=40);“31-40”;SI(B3>=41;“40 et +”;"")))))

Bonne journée,
Cordialement.


#3

merci bcp !

une autre solution m’a également été proposée entre temps :
=CHOISIR(EQUIV(D4;{18.26.31.41};1);“18-25”;“26-30”;“31-40”;“40+”)


#4

Bonsoir,

Très belle formule, beaucoup plus smart.
Bonne soirée.