Afficher une valeur en fonction de plusieurs critères textes

Bonjour,

J’ai une liste de mots qui contient ma marque de plusieurs orthographes (marque / mrque / marq…) mais aussi avec d’autres mots (ma marque / ta marq / sa mrque / ta super marque / ma marque de rêve…).

Je ne parviens pas à créer la fonction qui me permettrait d’afficher dans la colonne B le résultat “marque” (pour VRAI) ou “hors marque” (pour faux) si ma cellule A contient “marque” ou “marq” ou “mrque”.

J’ai celle-ci :
=SI(NB.SI(A2;“cadhoc”);“marque”;“hors marque”)
Mais elle ne me permet que de prendre en compte une orthographe de ma marque.

Et celle-ci (que je peux imbriquer plusieurs fois) :
=SI(A2=“cadhoc”;“marque”;“hors marque”)
Mais qui ne prend pas en compte si ma cellule contient d’autres mots.

Merci d’avance de votre aide !

Bonjour,
Sans classeur, pas de possibilité de trouver quoi que ce soit :face_with_raised_eyebrow:

Oui, autant pour moi !
Voici un fichier sur lequel je travaille pour test.

pour test.xlsx (37,7 Ko)

Re,

Teste avec cette formule

=SI(NB.SI(A1;"*ca**oc*");"marque";"hors marque")

Ca fonctionne assez bien mais quelques orthographes passent encore entre les mailles du filet : kadoc, kadhoc…

Le principe de cette formule est de repérer dans les cellules si elles contiennent ca ET oc ou ca OU oc ?

Re,

Teste comme ceci
=SI(NB.SI(A1;"*?a??oc*");"marque";"hors marque")

les “*” servent à ne pas prendre en compte les caractères avant et après
et le “?” ne prend pas en compte le caractères à cet emplacement

après, il n’y a pas d’autres solutions, EXCEL n’est pas non plus un dictionnaire automatique mais un tableur

Je te remercie mais ça ne rend pas le filtre que je souhaite faire.

Effectivement, il y a d’autres solutions je dois exploiter des données chiffrées après avoir filtré cette colonne contenant du texte. D’où mon choix d’Excel !

Merci à toi !

Si d’autres peuvent m’aider :slight_smile: